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Application Video Submission Requirements 

 
Please ensure that your video is shared to ‘Public’ or ‘Anyone with the Link’ until January of the 
grant award year. For a thorough review of your application, The USNDP Grant Committee will 
need to access the videos throughout the entirety of the performance evaluation process.  
 
Please DO NOT include links to personal websites or videos with slow motion or music.  
 
Share a link to either a: 

• YouTube Channel OR  
• Google Folder OR  
• Vimeo Folder 

 
Video less than 60 seconds in length or shots edited together (less than 2 minutes total 
of the following:  
 
Full Swing Video (1 video for all shots edited together) 

• 2 Clubs 
o Driver 
o 6-iron  

• 2 Angles  
o Down the target line 
o Face on 

 
Short Game Video (1 video for all shots edited together) 

• 3 Shots 
o Putt 
o Chip 
o Bunker 

• 1 Angle  
o Down the target line 

 
 
 
 
  



 

 

Recording the Videos 

Recommended Equipment 
• Smartphone or tablet 
• (optional) Tripod or stable surface to place the phone 
• Good lighting conditions 

 
Recording Tips 

• Ensuring good lighting: This is crucial for video quality. Good lighting helps capture clear 
details of the swing and ball flight. Natural daylight provides optimal lighting, but 
additional lighting is recommended when filming indoors or in low-light conditions. 

• Using a tripod: A steady camera is essential for capturing clear, professional-looking golf 
swing videos. A tripod eliminates camera shake and allows for consistent framing of 
shots. 

• We recommend video with limited noise and distractions.  
 

Angles to Capture 
• Down the Target Line: Position the phone directly behind the target line to capture the 

full swing and short game shots. 

 
• Face On: Position the phone perpendicular to the target line to capture your swing and 

short game shots from the side. 

 
 

Table of Contents      Editing Videos       Uploading Videos     Sharing Videos 

 



 

 

Editing the Videos 

Recommended Video Editing Apps 
• iPhone/iPad/Apple Macbook 

o iMovie (free) 
• Android  

o PowerDirector (free) 
 ARTICLE: Create Videos on Mobile Device in 3 Simple Steps 
 VIDEO: How to Trim & Split Demo Video 
 VIDEO: Editing Tips 

• Personal Computer (PC) 
o Microsoft Office ClipChamp (free with in-app purchases) 

Steps to Edit Your Videos 
 

Using iPhone/iPad     Using MacBook (Apple)     Using Microsoft ClipChamp (PC) 
 

Using iPhone or iPad 
1. Import Your Footage 

• Open your video editing app. 
• Import the recorded videos into the app. 

2. Trim and Edit Your Shots 
• Select the clips of each shot (full swing with driver and 6-iron, short game with 

putt, chip, and bunker). 
• Trim the clips to the desired length. 

3. Trim and arrange clips on iPhone or iPad (As Shown on iMovie) 
• After you add video clips and photos to the timeline of your project, you can 

make a clip longer or shorter, change the sequence of clips, or split a clip into two 
separate clips. 

4. Trim clips 
• You can trim a video clip or a photo so it appears for a shorter or longer period of 

time in your project.  

https://www.cyberlink.com/learning/powerdirector-video-editing-app/67/create-videos-on-a-mobile-device-in-3-simple-steps
https://www.cyberlink.com/learning/powerdirector-video-editing-app/281/how-to-trim-split-demo-video
https://www.cyberlink.com/learning/powerdirector-video-editing-app/1562/editing-tips-to-making-a-memorable-family-video-with-powerdirector-mobile-app
https://support.apple.com/guide/imovie-ipad/add-video-clips-and-photos-knac787725/ipados


 

 

• With your project open, tap the video clip or photo in the timeline. A yellow 
highlight appears around the selected clip. 

• To zoom in on the clip, pinch open in the center of the timeline. When you zoom 
in, you can see more detail in the clip, which can make it easier to edit. 

• Drag the beginning or end of the clip to make the clip shorter or longer: 
• To make the clip longer, drag the edge of the clip away from the center of the clip. 
• To make the clip shorter, drag the edge of the clip toward the center of the clip. 
• If you can't drag the edge of the clip, there might not be additional video at the 

beginning or end of that clip. For example, if you added a video clip that’s 20 
seconds long, you can’t make it longer than 20 seconds. It might also mean the 
clip is at the shortest length allowed by iMovie, which is 0.3 seconds. If you still 
want to change the duration of a clip, try changing the speed of the clip. 

5. Arrange clips 
• You can change the sequence of clips in the timeline to change when a particular 

clip appears in your movie. With your project open, touch and hold the video clip 
or photo in the timeline until it rises off the timeline, then drag the clip to a 
different location in the timeline. 

6. Split clips 
• When you split a clip, you can adjust the duration of each section, remove 

unwanted sections, or add different titles to each section. 
• Scroll in the timeline to position the play head (the white line) where you want to 

split the clip. 
• If necessary, pinch open in the center of the timeline to zoom in on the clip. 
• Tap the clip, tap the actions button , then tap Split. Or tap the clip, then swipe 

down over the play head on the clip, as if you were slicing through the clip with 
your finger. 
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Using MacBook (Apple) 
After you add video clips and photos to the timeline of your project, you can edit the audio on a 
clip,  make a clip longer or shorter, change the sequence of clips, or split a clip into two separate 
clips. 

1. Trim Clips 
You can trim a video clip or a photo so it appears for a shorter or longer period of time in 
your movie. 

 
• With your project open, scroll the timeline to locate the clip you want to trim. 
• To zoom in on the clip, choose View > Zoom In, press the Command–Plus sign 

(+), or pinch the trackpad. When you zoom in, you can see more detail in the clip, 
which can make it easier to edit. 

• In the timeline, hold the pointer over the beginning or end of the clip that you 

want to trim until your pointer becomes the clip trim tool . The arrows 
indicate which directions you can trim the clip: 

• To make the clip longer, drag the edge of the clip away from the center of the clip. 
• To make the clip shorter, drag the edge of the clip toward the center of the clip. 

If you can't drag the edge of the clip, it means there is no additional video at the beginning or 
end of that clip. For example, if you added a video clip that’s 20 seconds long, you can’t 
make it longer than 20 seconds. It might also mean the clip is at the shortest length allowed 
by iMovie, which is 0.1 seconds. If you still want to change the duration of a clip, 
try changing the speed of the clip. 

 

 

 

https://support.apple.com/guide/imovie/add-clips-mov42b64e075/mac
https://support.apple.com/guide/imovie/change-clip-speed-mov6c442b2eb/mac


 

 

2. Add or remove frames with the clip trimmer 
For more precise editing, you can use the clip trimmer to add or remove individual frames 
from a video clip. You can also see how much of your clip is being used in your movie. 

• In the timeline, select the clip you want to trim. 
• Choose Window > Show Clip Trimmer. The selected clip appears in the clip trimmer, 

above the timeline. The part of the clip that is visible in your movie appears between 
the two white lines, and the parts of your clip that don't appear in your movie are 
dimmed and outside the white lines. 

• Hold the pointer over the line at the beginning or end of the clip until the clip trim tool

 appears, then make the clip longer or shorter: 
o To make the clip longer by adding frames, drag away from the center of the 

clip. 
o To make the clip shorter by removing frames, drag toward the center of the 

clip. 

You can use a different portion of the same clip while maintaining its length in the project: 
• In the clip trimmer, hold the pointer over the clip until the clip trimmer tool

 appears. 
• Drag the selected portion of the clip left or right. 
• To close the clip trimmer, press Return. 

3. Arrange clips 
You can change the sequence of clips in the timeline to change when a particular clip 
appears in your movie. With your project open, click the video clip or photo in the timeline, 
then drag the clip left or right depending on where you want the clip to appear in your movie: 

• If you want the clip to appear earlier, drag the video clip to the left, then release. 
• If you want the clip to appear later, drag the video clip to the right, then release. 

You can also move multiple clips at once: 
1. Hold the Command key as you click each clip you want to select, drag a selection 

rectangle around the clips, or hold the Shift key as you click each clip. 
2. Drag the clips to a new location in the timeline. 

4. Split clips 
When you split a clip, you can adjust the duration of each section, remove unwanted 
sections, or add different titles to each section. 

1. Scroll in the timeline to position the play head (the white line) where you want to split 
the clip. 

2. If necessary, choose View > Zoom In or press Command–Plus sign (+) to zoom in on 
the clip. 

3. To split the clip, choose Modify > Split Clip or press Command-B. 
After you split the clip, add a transition like a cross-dissolve between the clips. 

 

https://support.apple.com/guide/imovie/add-transitions-movcaedc4dbd/mac


 

 

5. Combine Shots 
Arrange the clips in the following order: 

• Full Swing Video: Driver and 6-iron from down the target line and face on. 
• Short Game Video: Putt, chip, and bunker shots from down the target line. 

6. Add Transitions and Titles (Optional): 
• Add transitions between clips if needed. 
• Add titles to label each shot (e.g., "Driver - Down the Target Line"). 

7. Export the Final Video 
• Export the edited video in a suitable format (e.g., MP4). 
• Ensure the video quality is high (1080p recommended). 

8. Export a project 

• In the iMovie app  on your iPhone, tap a project in the Projects browser, tap 

the Share button  at the bottom of the screen, then tap Export Project. 
• Tap one of the following options: 

o AirDrop: Share wirelessly to a nearby Apple device using AirDrop. 
o Save to Files: Save the project to your iPhone, iPad, or iCloud Drive. 
o Mail: Export the project and send it in an email. 
o Messages: Export the project and send it in a text message 
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Using a Personal Computer (PC) – Microsoft Office ClimpChamp 

How to trim and cut clips using ClipChamp (For PC users) 
  

1. Select the video clip you want to split and position the seeker  
On the timeline, click the video you'd like to split. Your video will be highlighted green 
when selected. Next, move the seeker to the location on the timeline you would like to 
split your video clip. 

   

Note: Use the timecode above the timelines as a guide. For example, place your seeker 
at 01:30:00 for 1min 30 seconds.  

  

 

 

 

 

 

 



 

 

 

2.  Select the scissors icon  
 

Next, click on the video splitter button (scissors icon) on the timeline to split your video. 
You can also use the S key on your keyboard to access the split tool shortcut.  

  

Your video will now be split into two clips on the timeline.  

 

3. Delete unwanted split video clips  

To remove any split footage from your timeline, just click on the clip so it's highlighted 
green, then click on the delete button (trash can icon). Your clip will automatically delete 
from the timeline.  

 



 

 

 

4. Preview and save your video  

 

Before saving your new video, make sure to preview by clicking on the play button. When 
you’re ready to save, click on the export button and select a video resolution. We 
recommend saving all videos in 1080p video resolution.  

How to split video and audio clips at the same time  

Hold down the shift key on your keyboard and select both the video and audio clip on the 
timeline. You can also click and drag your mouse across both assets, which will select both of 
them. Next, move the seeker to where you want to split them. Then select the Split button.  

 

Note: If your audio is attached to your video, the audio will automatically split with the video. 

 
 

Table of Contents      Recording Videos    Editing Videos    Uploading Videos     Sharing Videos 
 
 

https://support.microsoft.com/en-us/topic/exporting-and-saving-a-video-in-clipchamp-e74795e7-e85c-4607-95bb-15e107aa4de2


 

 

 
Uploading the Videos 

YouTube 
VIDEO: How to upload to YouTube (Computer, Android, iPhone & iPad)  

1. Open the YouTube app and sign in. 
2. Tap the "+" icon at the bottom of the screen. 
3. Select "Upload a video" and choose the edited video file. 
4. Fill in the video details (title, description, etc.). 
5. Tap "Next" and then "Upload" to publish the video. 

Google Drive 
VIDEO: How to Upload to Google Drive (Computer, Android, iPhone & iPad) 

1. Open the Google Drive app and sign in. 
2. Tap the "+" button and select "Folder" to create a new folder. 
3. Open the folder and tap the "+" button again, then select "Upload." 
4. Choose the edited video file to upload. 

Vimeo 
VIDEO: How to Upload to Vimeo 

1. Open the Vimeo app and sign in. 
2. Tap the "+" icon and select "Upload." 
3. Choose the edited video file and fill in the video details. 
4. Tap "Upload" to publish the video. 

 
Sharing the Videos 

YouTube 
VIDEO: How to Share YouTube Videos 

1. Open the video on the YouTube app. 
2. Tap the "Share" button below the video. 
3. Copy the link provided and share it. 

Google Drive 
VIDEO: How to Share Google Drive Videos 

1. Open the Google Drive app and locate the uploaded video file. 
2. Tap the three dots next to the video and select "Get link." 
3. Ensure the link settings allow others to view the file. 
4. Copy the link and share it. 

Vimeo 
VIDEO: How to Share Vimeo Videos 

1. Open the video on the Vimeo app. 
2. Tap the "Share" button. 
3. Copy the link provided and share it. 
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https://support.google.com/youtube/answer/57407?hl=en&co=GENIE.Platform%3DDesktop&oco=1#zippy=
https://support.google.com/drive/answer/2424368?hl=en&co=GENIE.Platform%3DiOS&oco=1
https://help.vimeo.com/hc/en-us/articles/18774922216721-How-to-upload-a-video-to-Vimeo
https://youtu.be/c7OPll5sWqo?si=5aWtxLy8QiOsLLib
https://youtu.be/e7jpdaikaHA?si=5AS_uye-4ouYf3u2
https://help.vimeo.com/hc/en-us/articles/12426502519313-How-to-share-a-video#:%7E:text=Select%20the%20Share%20button%20in,link%20to%20share%20your%20video.

